hdu 4089||2011年北京現場賽I題 概率dp(公式不好推)

life4711發表於2014-11-03

http://acm.hdu.edu.cn/showproblem.php?pid=4089

Problem Description
After 4 years' waiting, the game "Chinese Paladin 5" finally comes out. Tomato is a crazy fan, and luckily he got the first release. Now he is at home, ready to begin his journey.
But before starting the game, he must first activate the product on the official site. There are too many passionate fans that the activation server cannot deal with all the requests at the same time, so all the players must wait in queue. Each time, the server deals with the request of the first player in the queue, and the result may be one of the following, each has a probability:
1. Activation failed: This happens with the probability of p1. The queue remains unchanged and the server will try to deal with the same request the next time.
2. Connection failed: This happens with the probability of p2. Something just happened and the first player in queue lost his connection with the server. The server will then remove his request from the queue. After that, the player will immediately connect to the server again and starts queuing at the tail of the queue.
3. Activation succeeded: This happens with the probability of p3. Congratulations, the player will leave the queue and enjoy the game himself.
4. Service unavailable: This happens with the probability of p4. Something just happened and the server is down. The website must shutdown the server at once. All the requests that are still in the queue will never be dealt.
Tomato thinks it sucks if the server is down while he is still waiting in the queue and there are no more than K-1 guys before him. And he wants to know the probability that this ugly thing happens.
To make it clear, we say three things may happen to Tomato: he succeeded activating the game; the server is down while he is in the queue and there are no more than K-1 guys before him; the server is down while he is in the queue and there are at least K guys before him.
Now you are to calculate the probability of the second thing.
 

Input
There are no more than 40 test cases. Each case in one line, contains three integers and four real numbers: N, M (1 <= M <= N <= 2000), K (K >= 1), p1, p2, p3, p4 (0 <= p1, p2, p3, p4 <= 1, p1 + p2 + p3 + p4 = 1), indicating there are N guys in the queue (the positions are numbered from 1 to N), and at the beginning Tomato is at the Mth position, with the probability p1, p2, p3, p4 mentioned above.
 

Output
A real number in one line for each case, the probability that the ugly thing happens.
The answer should be rounded to 5 digits after the decimal point.
 

Sample Input
2 2 1 0.1 0.2 0.3 0.4 3 2 1 0.4 0.3 0.2 0.1 4 2 3 0.16 0.16 0.16 0.52
 

Sample Output
0.30427 0.23280 0.90343
/**
解題思路摘自bin神部落格(有刪改)
HDU 4098
題意:有n個人排隊等著在官網上啟用遊戲。Tomato排在第m個。
對於佇列中的第一個人。有一下情況:
1、啟用失敗,留在佇列中等待下一次啟用(概率為p1)
2、失去連線,出佇列,然後排在佇列的最後(概率為p2)
3、啟用成功,離開佇列(概率為p3)
4、伺服器癱瘓,伺服器停止啟用,所有人都無法啟用了。
求伺服器癱瘓時Tomato在佇列中的位置<=k的概率

解析:
概率DP;
設dp[i][j]表示i個人排隊,Tomato排在第j個位置,達到目標狀態的概率(j<=i)
dp[n][m]就是所求
j==1:    dp[i][1]=p1*dp[i][1]+p2*dp[i][i]+p4;
2<=j<=k: dp[i][j]=p1*dp[i][j]+p2*dp[i][j-1]+p3*dp[i-1][j-1]+p4;
k<j<=i:  dp[i][j]=p1*dp[i][j]+p2*dp[i][j-1]+p3*dp[i-1][j-1];
化簡:
j==1:    dp[i][1]=p*dp[i][i]+p41;
2<=j<=k: dp[i][j]=p*dp[i][j-1]+p31*dp[i-1][j-1]+p41;
k<j<=i:  dp[i][j]=p*dp[i][j-1]+p31*dp[i-1][j-1];

其中:
p21=p2/(1-p1);
p31=p3/(1-p1)
p41=p4/(1-p1)

可以迴圈i=1->n 遞推求解dp[i][1~i].在求解dp[i][1~i]的時候dp[i-1][1~i-1]就相當於常數了。
在求解dp[i][1~i]時等到下列i個方程
j==1:   dp[i][1]=p21*dp[i][i]+c[1];
2<=j<=k:dp[i][j]=p21*dp[i][j-1]+c[j];
k<j=i:  dp[i][j]=p21*dp[i][j-1]+c[j];
其中c[j]都是常數了。上述方程可以解出dp[i][1~i]了。
首先是迭代得到 dp[i][i].然後再代入就可以得到所有的dp[i]了。

注意特判一種情況。就是p4<eps時候,就不會崩潰了,應該直接輸出0
*/
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
double pp[2005],dp[2005][2005],c[2005];
double p1,p2,p3,p4;
int n,m,k;
int main()
{
    while(~scanf("%d%d%d%lf%lf%lf%lf",&n,&m,&k,&p1,&p2,&p3,&p4))
    {
        if(p4<1e-5)
        {
            printf("0.00000\n");
            continue;
        }
        double p21=p2/(1-p1);
        double p31=p3/(1-p1);
        double p41=p4/(1-p1);
        pp[0]=1.0;
        for(int i=1;i<=n;i++)
            pp[i]=pp[i-1]*p21;
        dp[1][1]=p41/(1-p21);
        c[1]=p41;
        for(int i=2;i<=n;i++)
        {
            for(int j=2;j<=k;j++)
                c[j]=dp[i-1][j-1]*p31+p41;
            for(int j=k+1;j<=i;j++)
                c[j]=dp[i-1][j-1]*p31;
            double tmp=c[1]*pp[i-1];
            for(int j=2;j<=i;j++)
                tmp+=c[j]*pp[i-j];
            dp[i][i]=tmp/(1-pp[i]);
            dp[i][1]=p21*dp[i][i]+c[1];
            for(int j=2;j<i;j++)
                dp[i][j]=dp[i][j-1]*p21+c[j];
        }
        printf("%.5lf\n",dp[n][m]);
    }
    return 0;
}


相關文章