2014廣州網路賽1003||hdu 5024 搜尋
http://acm.hdu.edu.cn/showproblem.php?pid=5024
Wang Xifeng's Little Plot
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 264 Accepted Submission(s): 172
Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original
version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao's wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved
a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.
In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
Input
The map of Da Guan Yuan is represented by a matrix of characters '.' and '#'. A '.' stands for a part of road, and a '#' stands for other things which one cannot step onto. When standing on a '.', one can go to adjacent '.'s through 8 directions: north, north-west,
west, south-west, south, south-east,east and north-east.
There are several test cases.
For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.
Then the N × N matrix follows.
The input ends with N = 0.
There are several test cases.
For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.
Then the N × N matrix follows.
The input ends with N = 0.
Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai's rooms. A road's length is the number of '.'s it includes. It's guaranteed that for any test case, the maximum length is at least 2.
Sample Input
3
#.#
##.
..#
3
...
##.
..#
3
...
###
..#
3
...
##.
...
0
Sample Output
3
4
3
5
題目說迷宮行走的時候最多可以轉一個九十度的角,又因為只要是能有90度角,拐肯定比不拐距離長,因此我列舉每一個點然後從該點出發的每一對直角,然後直角兩端沿直線方向搜尋就行了,整個過程取最大的步數。
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int n,num,sum[10],maxx;
char a[105][105];
int point[8][2]= {{0,1},{1,0},{0,-1},{-1,0},{-1,-1},{1,1},{1,-1},{-1,1}};
bool judge(int x,int y)
{
if(x<n&&x>=0&&y<n&&y>=0)
return true;
return false;
}
void dfs(int x,int y,int t)
{
int xx=x+point[t][0];
int yy=y+point[t][1];
if(a[xx][yy]=='.'&&judge(xx,yy))
{
dfs(xx,yy,t);
num++;
}
}
void bfs(int x,int y)
{
for(int i=0; i<8; i++)
{
int xx=x+point[i][0];
int yy=y+point[i][1];
if(a[xx][yy]=='.'&&judge(xx,yy))
{
num=1;
dfs(xx,yy,i);
sum[i]=num;
}
}
/*for(int i=0;i<n;i++)
printf("%d ",sum[i]);
printf("\n");*/
maxx=max(maxx,sum[0]+sum[1]);
maxx=max(maxx,sum[1]+sum[2]);
maxx=max(maxx,sum[2]+sum[3]);
maxx=max(maxx,sum[3]+sum[0]);
maxx=max(maxx,sum[4]+sum[6]);
maxx=max(maxx,sum[7]+sum[5]);
maxx=max(maxx,sum[4]+sum[7]);
maxx=max(maxx,sum[6]+sum[5]);
}
int main()
{
while(~scanf("%d%*c",&n))
{
if(n==0)
break;
for(int i=0; i<n; i++)
scanf("%s",a[i]);
maxx=-1;
for(int i=0; i<n; i++)
for(int j=0; j<n; j++)
{
memset(sum,0,sizeof(sum));
if(a[i][j]=='.')
bfs(i,j);
}
printf("%d\n",maxx+1);
}
return 0;
}
相關文章
- HDU 2612 Find a way (廣搜)
- HDU 4620 Fruit Ninja Extreme(搜尋)UIREM
- hdu 1175 連連看 搜尋
- HDU1560,迭代加深搜尋
- hdu 1728 逃離迷宮 搜尋
- HDU 6415(dp/記憶化搜尋)
- 演算法競賽——BFS廣度優先搜尋演算法
- 中國網際網路首現搜尋框掛馬“114搜尋”被“黑”
- jzoj 6797. 【2014廣州市選day2】hanoi
- Btdog磁力搜尋、btdog網路電視
- c++ 廣度優先搜尋(寬搜)C++
- ybtoj:廣度優先搜尋
- bfs廣度優先搜尋
- 最佳路徑搜尋(二):啟發式搜尋(代價一致搜尋(Dijkstra search),貪心搜尋,A*搜尋)
- Flutter 網路搜尋引擎SEO優化友好Flutter優化
- Win10 20H1/20H2搜尋框如何禁用網路搜尋 Win10 20H1/20H2搜尋框禁用網路搜尋的步驟Win10
- 廣州牽引力教育 網際網路+企業應用人才名企雙選會廣州場來啦!
- 變革網路走進廣州東塔“智慧化”
- Tomcat和搜尋引擎網路爬蟲的攻防Tomcat爬蟲
- 圖的遍歷:深度優先搜尋與廣度優先搜尋
- Win10 Pro春季更新本地搜尋將預設載入網路搜尋結果Win10
- 圖的廣度優先搜尋和深度優先搜尋Python實現Python
- python 二叉樹深度優先搜尋和廣度優先搜尋Python二叉樹
- 搜狗搜尋推廣平臺下線
- 用開源搜尋引擎定製你的網際網路
- 各大網際網路巨頭的搜尋引擎交鋒PGB
- 啟發式搜尋的方式(深度優先,廣度優先)和 搜尋方法(Dijkstra‘s演算法,代價一致搜尋,貪心搜尋 ,A星搜尋)演算法
- [廣州]急尋一位Flutter高手兼職Flutter
- 127盤搜網 網盤資源搜尋引擎
- 關於廣州哪裡有開發具票-廣州本地網
- 基本演算法——深度優先搜尋(DFS)和廣度優先搜尋(BFS)演算法
- 網站搜尋功能lucene網站
- “2017網際網路+政務服務論壇”在廣州舉行
- EAS:基於網路轉換的神經網路結構搜尋 | AAAI 2018神經網路AI
- js版本的(廣、深)度優先搜尋JS
- SEMrush:2019年網路假潮牌搜尋排行榜
- 網路偵察技術(一)搜尋引擎資訊收集
- Redis 實戰 —— 10. 實現內容搜尋、定向廣告和職位搜尋Redis
- 廣州市委宣傳部領導蒞臨廣州綠盟城市網路安全運營中心調研指導