2014廣州網路賽1003||hdu 5024 搜尋

life4711發表於2014-09-22

http://acm.hdu.edu.cn/showproblem.php?pid=5024

Wang Xifeng's Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 264    Accepted Submission(s): 172


Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao's wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao. 

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
 

Input
The map of Da Guan Yuan is represented by a matrix of characters '.' and '#'. A '.' stands for a part of road, and a '#' stands for other things which one cannot step onto. When standing on a '.', one can go to adjacent '.'s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.
 

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai's rooms. A road's length is the number of '.'s it includes. It's guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
3 4 3 5
解題思路:

                 題目說迷宮行走的時候最多可以轉一個九十度的角,又因為只要是能有90度角,拐肯定比不拐距離長,因此我列舉每一個點然後從該點出發的每一對直角,然後直角兩端沿直線方向搜尋就行了,整個過程取最大的步數。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

int n,num,sum[10],maxx;
char a[105][105];
int point[8][2]= {{0,1},{1,0},{0,-1},{-1,0},{-1,-1},{1,1},{1,-1},{-1,1}};

bool judge(int x,int y)
{
    if(x<n&&x>=0&&y<n&&y>=0)
        return true;
    return false;
}

void dfs(int x,int y,int t)
{
    int xx=x+point[t][0];
    int yy=y+point[t][1];
    if(a[xx][yy]=='.'&&judge(xx,yy))
    {
        dfs(xx,yy,t);
        num++;
    }
}

void bfs(int x,int y)
{
    for(int i=0; i<8; i++)
    {
        int xx=x+point[i][0];
        int yy=y+point[i][1];
        if(a[xx][yy]=='.'&&judge(xx,yy))
        {
            num=1;
            dfs(xx,yy,i);
            sum[i]=num;
        }
    }
    /*for(int i=0;i<n;i++)
        printf("%d ",sum[i]);
    printf("\n");*/
    maxx=max(maxx,sum[0]+sum[1]);
    maxx=max(maxx,sum[1]+sum[2]);
    maxx=max(maxx,sum[2]+sum[3]);
    maxx=max(maxx,sum[3]+sum[0]);
    maxx=max(maxx,sum[4]+sum[6]);
    maxx=max(maxx,sum[7]+sum[5]);
    maxx=max(maxx,sum[4]+sum[7]);
    maxx=max(maxx,sum[6]+sum[5]);
}

int main()
{
    while(~scanf("%d%*c",&n))
    {
        if(n==0)
            break;
        for(int i=0; i<n; i++)
            scanf("%s",a[i]);
        maxx=-1;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                memset(sum,0,sizeof(sum));
                if(a[i][j]=='.')
                    bfs(i,j);
            }
        printf("%d\n",maxx+1);
    }
    return 0;
}



相關文章