2014多校聯合第十場A題||hdu 4971 最小割定理在最大權閉合圖上的應用

life4711發表於2014-09-11

http://acm.hdu.edu.cn/showproblem.php?pid=4971

Problem Description
There's a company with several projects to be done. Finish a project will get you profits. However, there are some technical problems for some specific projects. To solve the problem, the manager will train his employee which may cost his budget. There may be dependencies between technical problems, for example, A requires B means you need to solve problem B before solving problem A. If A requires B and B requires A, it means that you should solve them at the same time. You can select which problems to be solved and how to solve them freely before finish your projects. Can you tell me the maximum profit?
 

Input
The first line of the input is a single integer T(<=100) which is the number of test cases. 

Each test case contains a line with two integer n(<=20) and m(<=50) which is the number of project to select to complete and the number of technical problem.

Then a line with n integers. The i-th integer(<=1000) means the profit of complete the i-th project.

Then a line with m integers. The i-th integer(<=1000) means the cost of training to solve the i-th technical problem.

Then n lines. Each line contains some integers. The first integer k is the number of technical problems, followed by k integers implying the technical problems need to solve for the i-th project.

After that, there are m lines with each line contains m integers. If the i-th row of the j-th column is 1, it means that you need to solve the i-th problem before solve the j-th problem. Otherwise the i-th row of the j-th column is 0.
 

Output
For each test case, please output a line which is "Case #X: Y ", X means the number of the test case and Y means the the maximum profit.
 

Sample Input
4 2 3 10 10 6 6 6 2 0 1 2 1 2 0 1 0 1 0 0 0 0 0 2 3 10 10 8 10 6 1 0 1 2 0 1 0 1 0 0 0 0 0 2 3 10 10 8 10 6 1 0 1 2 0 1 0 0 0 0 0 0 0 2 3 10 10 8 10 6 1 0 1 2 0 0 0 1 0 0 0 0 0
 

Sample Output
Case #1: 2 Case #2: 4 Case #3: 4 Case #4: 6
    悲哀的是到今天才完成多校聯合的題目==從這道題開始我再寫部落格的時候不在寫題目的大意了,太浪費青春了。。。

解題思路:最大權閉合圖問題,經典解法見胡伯濤的論文,最小割模型在資訊學競賽中的應用,有一個公式:最大權閉合圖的權值=所有的正權邊 - 最小割。

程式碼如下:

#include<cstdio>
#include<iostream>
using namespace std;
const int oo=1e9;

const int mm=111111;

const int mn=999;

int node,src,dest,edge;

int ver[mm],flow[mm],next[mm];

int head[mn],work[mn],dis[mn],q[mn];
void prepare(int _node,int _src,int _dest)
{
    node=_node,src=_src,dest=_dest;
    for(int i=0; i<node; ++i)head[i]=-1;
    edge=0;
}
void addedge(int u,int v,int c)
{
    ver[edge]=v,flow[edge]=c,next[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,next[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=src]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=next[i])
            if(flow[i]&&dis[v=ver[i]]<0)
            {
                dis[q[r++]=v]=dis[u]+1;
                if(v==dest)return 1;
            }
    return 0;
}
int Dinic_dfs(int u,int exp)
{
    if(u==dest)return exp;
    for(int &i=work[u],v,tmp; i>=0; i=next[i])
        if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
        {
            flow[i]-=tmp;
            flow[i^1]+=tmp;
            return tmp;
        }
    return 0;
}
int Dinic_flow()
{
    int i,ret=0,delta;
    while(Dinic_bfs())
    {
        for(i=0; i<node; ++i)work[i]=head[i];
        while(delta=Dinic_dfs(src,oo))ret+=delta;
    }
    return ret;
}
int n,m;
 int main()
 {
     int T,tt=0;
     scanf("%d",&T);
     while(T--)
     {
         scanf("%d%d",&n,&m);
         prepare(n+m+2,0,n+m+1);
         int x,sum=0;
         for(int i=1;i<=n;i++)
         {
            scanf("%d",&x);
            sum+=x;
            addedge(src,i,x);
         }
         for(int i=n+1;i<=n+m;i++)
         {
             scanf("%d",&x);
             addedge(i,dest,x);
         }
         int k;
         for(int i=1;i<=n;i++)
         {
             scanf("%d",&k);
             while(k--)
             {
                 scanf("%d",&x);
                 addedge(i,x+n+1,oo);
             }
         }
         for(int i=n+1;i<=m+n;i++)
            for(int j=n+1;j<=m+n;j++)
            {
                scanf("%d",&x);
                if(x&1)
                    addedge(i,j,oo);
            }
        printf("Case #%d: %d\n",++tt,sum-Dinic_flow());
     }
     return 0;
 }



相關文章