2013成都站F題||hdu4786 並查集 生成樹

life4711發表於2014-08-28

http://acm.hdu.edu.cn/showproblem.php?pid=4786

Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 105) and M(0 <= M <= 105).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
Case #1: Yes Case #2: No
題目大意:給定一個圖,確定是一個連通圖。每條邊有一定的顏色,黑或白。求是否有這樣一棵生成樹保證所有的樹邊的總數為一個Fibonacci數。

解題思路:

               按邊的顏色排序兩次,一次黑邊優先,利用並查集構造一個生成樹,此時是所有方法中白邊最少的情況,x。而後白邊優先,得出的是白邊最多的情況,y。找找x,y二者之間是否包括一個Fibonacci數即可。

#include <string.h>
#include <stdio.h>
#include <iostream>
#include <algorithm>
//#define debug
using namespace std;
struct note
{
    int u,v,c;
} edge[100005];
int n,m,fa[100005],num;
bool cmp1(note a,note b)
{
    return a.c<b.c;
}
bool cmp2(note a,note b)
{
    return a.c>b.c;
}
void initset()
{
    for(int i=0; i<=n; i++)
        fa[i]=i;
}
int find(int x)
{
    if(x==fa[x])
        return x;
    return fa[x]=find(fa[x]);
}
int un(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        fa[y]=x;
        num++;
        return 1;
    }
    return 0;
}
int a[1005];
void fib()
{
    a[0]=1;
    a[1]=1;
    for(int i=2; i<30; i++)
        a[i]=a[i-1]+a[i-2];
#ifdef debug
    printf("%d\n",a[29]);
#endif // debug
}
int main()
{
    int T,tt=0;
    scanf("%d",&T);
    fib();
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].c);
        initset();
        sort(edge,edge+m,cmp1);
        int cnt1;
        num=0;
        int count=0;
        for(int i=0; i<m; i++)
        {
            if(un(edge[i].u,edge[i].v))
                count+=edge[i].c;
            if(num==n-1)
            {
                cnt1=count;
                break;
            }
        }
        initset();
        sort(edge,edge+m,cmp2);
        int cnt2;
        num=0;
        count=0;
        for(int i=0; i<m; i++)
        {
            if(un(edge[i].u,edge[i].v))
                count+=edge[i].c;
            if(num==n-1)
            {
                cnt2=count;
                break;
            }
        }
        int flag=0;
        for(int i=0; i<29; i++)
            if(cnt1==a[i]||cnt2==a[i])
            {
                printf("Case #%d: Yes\n",++tt);
                flag=1;
                break;
            }
        if(flag)
            continue;
        int x=upper_bound(a,a+29,cnt1)-a;
        int y=upper_bound(a,a+29,cnt2)-a;
        if(x==y)
            printf("Case #%d: No\n",++tt);
        else
            printf("Case #%d: Yes\n",++tt);
    }
    return 0;
}


相關文章