2014多校聯合第9場1011題||hdu 4970 樹狀陣列

life4711發表於2014-08-19

http://acm.hdu.edu.cn/showproblem.php?pid=4970

Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.
 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.
 

Output
Output one line containing the number of surviving monsters.
 

Sample Input
5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0
 

Sample Output
3
Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.
題目大意:給定一個區間(1,n)其中一些子區間(l,r)對應各個點有一定的值,給出m組資料x,y求從y點到n點各點的值之和小於x的點的個數

樹狀陣列:查詢操作sum(i)返回的是i點的值不是前i個點的值,這裡注意,我一直認為錯了

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
int c[100005],n,m;
LL s[100005];
LL lowbit(LL x)
{
    return x&(-x);
}
LL sum(int x)
{
    LL ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(c,0,sizeof(c));
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            int l,r,w;
            scanf("%d%d%d",&l,&r,&w);
            add(l,w);
            add(r+1,-w);
        }
        /*for(int i=1;i<=n;i++)
            printf("%d ",c[i]);
        printf("\n");
        for(int i=1;i<=n;i++)
            printf("%I64d\n",sum(i));*/
        for(int i=1;i<=n;i++)
           s[i]=sum(i);
        for(int i=n-1;i>=1;i--)
            s[i]+=s[i+1];
        scanf("%d",&m);
        LL x;
        int y;
        int cnt=0;
        for(int i=0;i<m;i++)
        {
            scanf("%I64d%d",&x,&y);
            if(s[y]<x)
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}


相關文章