UVA-LA 3135 2004年北京站C題 STL priority_queue自定義優先順序優先佇列的使用

life4711發表於2014-08-12

https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1136

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input 

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of �#�.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output 

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input 

Register 2004 200
Register 2005 300
#
5

Sample Output 

2004
2005
2004
2004
2005
題目大意:編寫一個稱為:Argus的系統。該系統支援一個register命令。該命令註冊一個觸發器,她每period秒鐘就會產生一個編號為Q_num的事件。你的任務是模擬出前k個事件。如果有多個事件同時發生,先處理Q_num小的事件。

解題思路:用優先佇列維護每個觸發器的“下一個事件”,然後每次從中取出最早發生的一個事件重複k次即可,。任意時刻優先佇列中都是n個元素,因此總的時間複雜度為O(klogn)。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
struct note
{
    int time,q_time,period;
    //重要!優先順序比較函式。優先順序高的先出隊
    bool operator < (const note & a)const//這裡的const必不可少
    {
        return (time>a.time||time==a.time&&q_time>a.q_time);
    }
};
priority_queue <note>  que;
int main()
{
   char a[20];
   while(~scanf("%s",a)&&a[0]!='#')
   {
       note p;
       scanf("%d%d",&p.q_time,&p.period);
       p.time=p.period;//初始化“下一次事件的時間”為它的週期
       que.push(p);
   }
   int m;
   scanf("%d",&m);
   while(m--)
   {
       note r=que.top();//取下一個事件
       que.pop();
       printf("%d\n",r.q_time);
       r.time+=r.period;//更新該觸發器下一個事件的時間
       que.push(r);//重新插入優先佇列
   }
   return 0;
}


相關文章