UVA-LA 3135 2004年北京站C題 STL priority_queue自定義優先順序優先佇列的使用
A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�
We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Register Q_num Period
Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.
Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.
Input
The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of �#�.
The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).
Output
You should output the Q_num of the first K queries to return the results, one number per line.
Sample Input
Register 2004 200 Register 2005 300 # 5
Sample Output
2004 2005 2004 2004 2005題目大意:編寫一個稱為:Argus的系統。該系統支援一個register命令。該命令註冊一個觸發器,她每period秒鐘就會產生一個編號為Q_num的事件。你的任務是模擬出前k個事件。如果有多個事件同時發生,先處理Q_num小的事件。
解題思路:用優先佇列維護每個觸發器的“下一個事件”,然後每次從中取出最早發生的一個事件重複k次即可,。任意時刻優先佇列中都是n個元素,因此總的時間複雜度為O(klogn)。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
struct note
{
int time,q_time,period;
//重要!優先順序比較函式。優先順序高的先出隊
bool operator < (const note & a)const//這裡的const必不可少
{
return (time>a.time||time==a.time&&q_time>a.q_time);
}
};
priority_queue <note> que;
int main()
{
char a[20];
while(~scanf("%s",a)&&a[0]!='#')
{
note p;
scanf("%d%d",&p.q_time,&p.period);
p.time=p.period;//初始化“下一次事件的時間”為它的週期
que.push(p);
}
int m;
scanf("%d",&m);
while(m--)
{
note r=que.top();//取下一個事件
que.pop();
printf("%d\n",r.q_time);
r.time+=r.period;//更新該觸發器下一個事件的時間
que.push(r);//重新插入優先佇列
}
return 0;
}
相關文章
- C++ STL 優先佇列 (priority_queue)C++佇列
- STL(二十)priority_queue優先佇列容器佇列
- 封裝優先順序佇列封裝佇列
- 棧,佇列,優先順序佇列簡單介面使用佇列
- STL 優先佇列 用法佇列
- Java優先順序佇列DelayedWorkQueue原理分析Java佇列
- Facebook的分散式優先順序佇列FOQS分散式佇列
- Redis實現任務佇列、優先順序佇列Redis佇列
- 佇列 優先順序佇列 python 程式碼實現佇列Python
- STL優先佇列最小堆最大堆佇列
- STL醜數(set+優先佇列)佇列
- 原始碼解析C#中PriorityQueue(優先順序佇列)的實現原始碼C#佇列
- CSS優先順序CSS
- [PY3]——實現一個優先順序佇列佇列
- [演算法系列之四]優先順序佇列演算法佇列
- 個推基於 Apache Pulsar 的優先順序佇列方案Apache佇列
- RMQ——支援合併和優先順序的訊息佇列MQ佇列
- C++運算子優先順序C++
- Python3 執行緒優先順序佇列( Queue)Python執行緒佇列
- Python 列表推導及優先順序佇列的實現Python佇列
- 中斷優先順序
- C 語言運算子優先順序
- C語言運算子優先順序C語言
- C++運算子優先順序特例C++
- C++ 運算子優先順序表C++
- C++操作符的優先順序C++
- PHP優先佇列PHP佇列
- 堆--優先佇列佇列
- 優先佇列 (轉)佇列
- Android程式優先順序Android
- SQL 優先順序join>whereSQL
- java運算子優先順序Java
- nginx快取優先順序Nginx快取
- php運算子優先順序PHP
- css優先順序彙總CSS
- [譯]HTTP/2的優先順序HTTP
- CSS的處理優先順序CSS
- 【堆】【優先佇列】[NOIP2004]合併果子佇列