UVA 11235 經典RMQ問題
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=2176
University of Ulm Local Contest
Problem F: Frequent values
You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.
Input Specification
The input consists of several test cases. Each test case starts with a line containing two integers n and q(1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the query.
The last test case is followed by a line containing a single 0.
Output Specification
For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.
Sample Input
10 3 -1 -1 1 1 1 1 3 10 10 10 2 3 1 10 5 10 0
Sample Output
1 4 3
A naive algorithm may not run in time!
題目大意:
給出一個非降序的排列的整數陣列a1,a2,a3...an,你的任務是對於一系列的詢問(i,j),回答ai,ai+1,....aj,中出現次數最多的值所出現的次數。
解題思路:RMQ範圍最小值問題(大白書P197)
應注意到整個陣列是非降序的,所有相等的元素都會聚集到一起。這樣就可以把整個陣列進行遊程編碼。比如:-1,1,1,2,2,2,4就可以編碼成(-1,1),(1,2),(2,3),(4,1),其中(a,b)表示b個連續的a。用value[i]和count[j]分別表示第i段的數值和出現的次數,num[p],left[p],right[p]分別表示位置p所在段的編號和左右端點的位置,則在下圖的情況,每次查詢(L,R)的結果為以下三個部分的最大值:從L到L所在段的結束處的元素個數(即right[L]-L+1)、從R所在段的開始處到R處的元素個數(即R-left[R]-1)、中間第num[L]+1段到第num[R]-1段的count的最大值。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=110005;
const int inf=2e9;
int num[maxn],_left[maxn],_right[maxn],cnt[maxn],d[maxn][30];
int pre,n,m;
int RLE()//遊程編碼
{
int x,l=0,count=-1;
pre=inf;
int size;
for(int i=0; i<n; i++)
{
scanf("%d",&x);
if(x!=pre)
{
for(int j=l; j<i; j++)
_right[j]=i-1;
l=i;
_left[i]=l;
count++;
pre=x;
num[i]=count;
cnt[count]=1;
}
else
{
_left[i]=l;
num[i]=count;
cnt[count]++;
}
}
for(int i=l; i<n; i++)
_right[i]=n-1;
size=count+1;
return size;
/**
printf("\n\n");
for(int i=0;i<n;i++)
printf("%d ",_left[i]);
printf("\n");
for(int i=0;i<n;i++)
printf("%d ",num[i]);
printf("\n");
for(int i=0;i<n;i++)
printf("%d ",cnt[i]);
printf("\n");
for(int i=0;i<n;i++)
printf("%d ",_right[i]);
printf("\n");
**/
}
void RMQ_init()
{
int n=RLE();
for(int i=0;i<n;i++)
d[i][0]=cnt[i];
for(int j=1;(1<<j)<=n;j++)
for(int i=0;i+(1<<j)-1<n;i++)
d[i][j]=max(d[i][j-1],d[i+(1<<(j-1))][j-1]);
}
int RMQ_query(int l,int r)
{
if(l>r)
return 0;
int k=0;
while((1<<(k+1))<=r-l+1)k++;//如果2^(k+1)<=r-l+1,那麼k還可以加1
return max(d[l][k],d[r-(1<<k)+1][k]);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n==0)
break;
RMQ_init();
while(m--)
{
int l,r;
scanf("%d%d",&l,&r);
l--;
r--;
if(num[l]==num[r])
{
printf("%d\n",r-l+1);
continue;
}
int t1=_right[l]-l+1;
int t2=r-_left[r]+1;
int t3=RMQ_query(num[l]+1,num[r]-1);
printf("%d\n",max(t1,max(t2,t3)));
}
}
return 0;
}
相關文章
- UVA 11235-Frequent values(RMQ)MQ
- POJ 3368 Frequent values (UVA 11235)(RMQ)MQ
- $RMQ$問題($ST$表)MQ
- 八數碼 經典問題
- RMQ問題的各種解法MQ
- UVA 673 括號的匹配——經典棧的應用
- SQL language裡面的經典問題SQL
- 揹包問題的一道經典問題
- 七大快取經典問題快取
- 經典演算法-最大流問題演算法
- CSS 佈局經典問題初步整理CSS
- google經典演算法面試題-雞蛋問題Go演算法面試題
- 經典面試問題:12小球問題演算法(原始碼)面試演算法原始碼
- 資料結構——RMQ(ST表)問題資料結構MQ
- 經典面試題面試題
- AT 經典90題
- 【C++】 55_經典問題分析 四C++
- oracle經典亂碼問題——靠靠靠靠Oracle
- 30 個 Openstack 經典面試問題和解答面試
- c 語言指標操作經典問題指標
- 全面解析快取應用經典問題快取
- CSS中越界問題經典解決方案CSS
- 機器學習教材中的 7 大經典問題機器學習
- 5個經典的前端面試問題前端面試
- 16個經典面試問題及回答思路面試
- TCP通訊之經典問題解決TCP
- POJ 3264 Balanced Lineup【RMQ問題】MQ
- 經典的 Top K 問題,你真的懂了麼?
- 70個經典面試問題,有備無患~面試
- 使用 JavaScript 解決經典爬樓梯問題JavaScript
- Dreamweaver製作網頁經典問題大整理網頁
- 【經典演算法問題】馬的遍歷【回溯】演算法
- 四個經典的SQL程式設計問題SQL程式設計
- GCD&&LCM的一些經典問題GC
- 70個經典的 Shell 指令碼面試問題指令碼面試
- 5個經典的JavaScript面試基礎問題JavaScript面試
- poj 1182 並查集經典問題並查集
- 經典n皇后問題java程式碼實現Java