hdu 3117矩陣+斐波那契數列
http://acm.hdu.edu.cn/showproblem.php?pid=3117
Fibonacci Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1720 Accepted Submission(s): 681
Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.
What is the numerical value of the nth Fibonacci number?
What is the numerical value of the nth Fibonacci number?
Input
For each test case, a line will contain an integer i between 0 and 108 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the
first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).
There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
64
65
Sample Output
0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023...4155
1061...7723
1716...7565
大體思路:本題考查了斐波那契數列的運算,當然當n很小的情況下可以運用for迴圈求出,如果一旦n爆掉long long 那麼我們對於本題該怎麼求呢,首先,介紹一下對於斐波那契數列前幾位數的求法
而對於求後幾位我們完全可以利用矩陣來求,不能直接取模複雜度必須降到lg(n)。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int a[100];
const int MAX=2;
struct Matrix
{
long long m[MAX][MAX];
};
Matrix P={0,1,
1,1};
Matrix I={1,0,
0,1};
Matrix matrixmul(Matrix a,Matrix b)
{
int i,j,k;
Matrix c;
for(i=0;i<MAX;i++)
for(j=0;j<MAX;j++)
{
c.m[i][j]=0;
for(k=0;k<MAX;k++)
c.m[i][j]+=(a.m[i][k]*b.m[k][j])%10000;
c.m[i][j]%=10000;
}
return c;
}
Matrix quickpow(long long n)
{
Matrix m=P,b=I;
while(n>=1)
{
if(n&1)
b=matrixmul(b,m);
n=n>>1;
m=matrixmul(m,m);
}
return b;
}
int main()
{
int n;
a[0]=0;
a[1]=1;
int temp;
for(int i=2;;i++)
if(a[i-1]+a[i-2]>99999999)
{
temp=i-1;
break;
}
else
a[i]=a[i-1]+a[i-2];
while(~scanf("%d",&n))
{
Matrix tmp;
tmp=quickpow(n);
int ans_e=tmp.m[0][1];
if(n<=temp)
printf("%d\n",a[n]);
else
{
int d;
double len=0.0;
len=log10(1.0/sqrt(5)) +(double)n*log10((1.0+sqrt(5))/2.0);
d=(int)(pow(10,len-(int)len+3));
printf("%d...%04d\n",d,ans_e);//將ans_e用0補齊四位
}
}
return 0;
}
相關文章
- 斐波那契數列Ⅳ【矩陣乘法】矩陣
- HDU 4549 M斐波那契數列(矩陣快速冪+費馬小定理)矩陣
- 斐波那契數列
- 斐波那契數列(Java)Java
- 從斐波那契到矩陣快速冪矩陣
- 斐波那契數列詳解
- 著名的斐波那契數列
- 斐波那契數列 (C#)C#
- PHP 與斐波那契數列PHP
- 斐波那契數
- [C103] 斐波那契數列
- 力扣之斐波那契數列力扣
- 斐波那契數列js 實現JS
- 劍指offer——斐波那契數列
- js實現斐波那契數列JS
- 斐波那契數列演算法演算法
- 第十題:斐波那契數列
- 使用Python實現斐波那契數列Python
- 演算法(1)斐波那契數列演算法
- 斐波那契數列的來源——數兔子
- 斐波那契數列數與等冪和
- LeetCode 509[斐波那契數]LeetCode
- Leedcode-斐波那契數
- 509. 斐波那契數
- 一千位斐波那契數
- JavaScript 實現:輸出斐波那契數列JavaScript
- js迭代器實現斐波那契數列JS
- offer通過--9斐波那契數列-2
- 演算法一:斐波那契阿數列演算法
- 大數斐波那契數列的演算法演算法
- 斐波那契數列:7數5層魔法塔(3)
- 斐波那契數列:7數5層魔法塔(2)
- 斐波那契數列:7數5層魔法塔(5)
- 斐波那契數列:7數5層魔法塔(8)
- 斐波那契數列:7數5層魔法塔(13)
- 斐波那契數列:7數5層魔法塔(12)
- 斐波那契數列:7數5層魔法塔(10)
- 斐波那契數列:7數5層魔法塔(11)
- 斐波那契數列:7數5層魔法塔(7)