POJ 3981 字串替換

sinchb發表於2012-10-18

一、題目資訊

字串替換
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7501   Accepted: 3560

Description

編寫一個C程式實現將字串中的所有"you"替換成"we"

Input

輸入包含多行資料 

每行資料是一個字串,長度不超過1000 
資料以EOF結束

Output

對於輸入的每一行,輸出替換後的字串

Sample Input

you are what you do

Sample Output

we are what we do

二、參考程式碼

#include <string> 
#include <iostream>
using namespace std;
int main()
{
    string str;
    while(getline(cin,str))
    {
        string::size_type pos = 0;
        while ( (pos = str.find("you", pos)) != string::npos ) {
            str.replace( pos++, 3, "we" );
        }
        cout << str << endl;
    }
    return 0;
}


相關文章