hdu1047 Integer Inquiry
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Sample Input
1
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670
解題思路:
- 高精度加法,將和定義為int型別,讀入的每個資料定義為char型別;
- 讀入資料時將資料倒著,資料本身的最高位作為
a[0]
,這樣就可以不在資料前補零了;讀入資料是會有資料前存在0的情況,這個可以在讀入時忽略; - 從最低位加和,將進位加到高位去
- 判斷求出的和前是否有0
#include <stdio.h>
#include <string.h>
int a[110];
char str[110],s[110];
void add(char s[],int a[])
{
int b[110];
int i,j,len;
memset(b,0,sizeof(b));
len=strlen(s);
for(i=0;i<len;i++)
{
b[len-i-1]=s[i]-'0';//倒著儲存,把最高位的值放在靠後的位置
}
for(i=0;i<len;i++)
{
a[i]+=b[i];
if(a[i]>9)
{
a[i]-=10;
a[i+1]++;
}
}
}
int main ()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(a,0,sizeof(a));
while(scanf("%s",str)&&strcmp(str,"0")!=0)
add(str,a);
int i;
for(i=109;i>0;i--)//判斷a前的0
if(a[i]!=0)
break;
for(;i>=0;i--)
printf("%d",a[i]);
printf("\n");
if(T!=0)
printf("\n");
}
return 0;
}
相關文章
- POJ-1503 Integer Inquiry-多個大數相加UI
- AWR報告分析之二:ges inquiry response 過高UI
- 學習PLS_INTEGER,BINARY_INTEGER,INTEGER,NUMBER的概念及效能差異
- Integer比較
- AWR報告分析之二:ges inquiry response 過高-eygleUI
- Integer的比較
- [Java基礎]IntegerJava
- 走進 JDK 之 IntegerJDK
- Leetcode Integer to RomanLeetCode
- leetcode Reverse IntegerLeetCode
- leetcode Roman to IntegerLeetCode
- [LeetCode] Roman to IntegerLeetCode
- pls_integer型別型別
- Leetcode 12 Integer to RomanLeetCode
- Leetcode 13 Roman to IntegerLeetCode
- Leetcode 7 Reverse IntegerLeetCode
- Java Integer的快取策略Java快取
- Integer轉int出現NullPointExceptionNullException
- int與Integer的區別
- ibatis中integer型別BAT型別
- int和Integer的區別
- LeetCode-Integer ReplacementLeetCode
- Java Integer型別比較Java型別
- LeetCode-Integer BreaksLeetCode
- 使用pls_integer型別型別
- Leetcode-Roman to IntegerLeetCode
- Leetcode-Integer to RomanLeetCode
- Reverse Integer leetcode javaLeetCodeJava
- Integer to Roman leetcode javaLeetCodeJava
- Roman to Integer leetcode javaLeetCodeJava
- Integer 自動拆箱封箱
- Hold住面試官之Integer Cache面試
- 從JDK原始碼角度看IntegerJDK原始碼
- JDK原始碼閱讀-Integer類JDK原始碼
- Integer128==128?falseFalse
- Leetcode 273 Integer to English WordsLeetCode
- java基礎:Integer — 原始碼分析Java原始碼
- Leetcode 12. Integer to RomanLeetCode