hdu1047 Integer Inquiry

是帥哥哥啊發表於2017-11-23
 One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

解題思路:

  • 高精度加法,將和定義為int型別,讀入的每個資料定義為char型別;
  • 讀入資料時將資料倒著,資料本身的最高位作為a[0],這樣就可以不在資料前補零了;讀入資料是會有資料前存在0的情況,這個可以在讀入時忽略;
  • 從最低位加和,將進位加到高位去
  • 判斷求出的和前是否有0
#include <stdio.h>
#include <string.h>
int a[110];
char str[110],s[110];
void add(char s[],int a[])
{
    int b[110];
    int i,j,len;
    memset(b,0,sizeof(b));
    len=strlen(s);
    for(i=0;i<len;i++)
    {
        b[len-i-1]=s[i]-'0';//倒著儲存,把最高位的值放在靠後的位置 
    }
    for(i=0;i<len;i++)
    {
        a[i]+=b[i];
        if(a[i]>9)
        {
            a[i]-=10;
            a[i+1]++;
        }
     } 
}
int main ()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(a,0,sizeof(a));
        while(scanf("%s",str)&&strcmp(str,"0")!=0)
            add(str,a);
        int i;
        for(i=109;i>0;i--)//判斷a前的0
            if(a[i]!=0)
                break;
        for(;i>=0;i--)
            printf("%d",a[i]);
        printf("\n");
        if(T!=0)
             printf("\n");
    }
    return 0;
}

相關文章