山東省第八屆 ACM 省賽 quadratic equation (水、坑)
Problem Description
With given integers a,b,c, you are asked to judge whether the following statement is true: “For any x, if
a⋅x2+b⋅x2+c=0 a⋅x^2+b⋅x^2+c=0, then x is an integer.”
Input
The first line contains only one integer T(1≤T≤2000), which indicates the number of test cases.
For each test case, there is only one line containing three integers a,b,c(−5≤a,b,c≤5).
Output
or each test case, output “YES” if the statement is true, or “NO” if not.
Example Input
3
1 4 4
0 0 1
1 3 1
Example Output
YES
YES
NO
題意
給出 a,b,c
,判斷
a⋅x^2+b⋅x^2+c=0
是否有非整數解,若有,輸出 NO
,否則輸出 YES
。
思路
從測試資料可以看出如果原方程式無實數解時輸出 YES
。
於是便是很多很多的 if
啦!
注意:這題有坑、這題有坑、這題有坑,如果 a,b,c 都是 0 的情況 x 可以取任意實數,所以輸出 NO
如果沒有這個坑,可能省賽的時候就是穩金了,憂傷~
AC 程式碼
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
#include<queue>
#include<map>
#define eps (1e-8)
bool jud(int a,int b,int c)
{
if(a==0)
{
if(b==0)
{
if(c==0)return false; // 已心痛的坑
return true;
}
else if(c%b==0)return true;
return false;
}
double der=b*b-4*a*c;
int s=(int)sqrt(der);
if(der<0)return true;
if(fabs(s-sqrt(der))<eps)
if((-b+s)%(2*a)==0&&(-b-s)%(2*a)==0)return true;
return false;
}
int main()
{
int T;
scanf("%d",&T);
for(int i=0; i<T; i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
printf(jud(a,b,c)?"YES\n":"NO\n");
}
return 0;
}
相關文章
- 第八屆山東省ACM大學生程式設計競賽總結ACM程式設計
- 山東省第四屆acm解題報告(部分)ACM
- 24山東省賽wp
- 山東省第七屆ACM大學生程式設計競賽-Reversed WordsACM程式設計
- 山東省第一屆ACM大學生程式設計競賽-Balloons(搜尋)ACM程式設計
- 2019山東ACM省賽補題題解ACM
- 山東省第六屆ACM大學生程式設計競賽-Square Number(完全平方數)ACM程式設計
- 山東省第六屆ACM大學生程式設計競賽-Lowest Unique Price(桶排序)ACM程式設計排序
- 山東省第四屆ACM大學生程式設計競賽-Contest Print Server(模擬)ACM程式設計Server
- 山東省第四屆ACM大學生程式設計競賽-Rescue The Princess(計算幾何)ACM程式設計
- 山東省第六屆ACM大學生程式設計競賽-Single Round Math(大數除法)ACM程式設計
- 2012年"浪潮杯"山東省第三屆ACM大學生程式設計競賽(熱身賽)ACM程式設計
- 我校學子在山東省ACM競賽中獲得優異成績ACM
- 山東省第四屆ACM大學生程式設計競賽-Alice and Bob(二進位制&&找規律)ACM程式設計
- 九州信泰杯 第十一屆山東省網路安全技能大賽
- 第十屆山東省大學生程式設計競賽題解(A、F、M、C)程式設計
- 2024CCPC山東省賽補題記錄
- 藍橋杯__省賽__第八屆__C/C++__大學A組C++
- 山東省第四屆ACM大學生程式設計競賽-Boring Counting(劃分樹-二分查詢)ACM程式設計
- 10.5組隊訓練賽-2024CCPC山東省賽
- 山東省第五屆ACM大學生程式設計競賽-Full Binary Tree(二叉樹&&求任意兩節點路徑)ACM程式設計二叉樹
- 山東省第五屆ACM大學生程式設計競賽-Hearthstone II(組合數學-第二類Stirling數)ACM程式設計
- 2017第二屆廣東省強網杯線上賽- who are you
- 第十屆省賽 B題.情報傳遞
- 第十三屆藍橋杯省賽A組
- 【山東CIO智庫活動】山東省兩化融合深度行菏澤站成功舉辦
- 2014年藍橋杯程式設計大賽山東省賽區成績公佈程式設計
- 2017第八屆天梯賽省賽C++C組【第一題:貪吃蛇長度】C++
- 模擬比賽-14屆研究生組C++省賽C++
- 山東省軟體評測中心專家解讀資訊化
- 2017第八屆藍橋杯C/C++ B組省賽第二題 秒解C++
- 省賽總結
- 第六屆藍橋杯省賽CC++B組C++
- 超越挑戰|廣東省資訊通訊行業第三屆網路安全技能大賽行業
- 2019年度山東省旅遊大資料包告大資料
- 藍橋杯__省賽__第七屆__C/C++__大學A組C++
- 藍橋杯__省賽__第九屆__C/C++__大學A組C++
- 歷屆藍橋杯省賽(C、C++)的答案(轉)C++