hdu1025 最大遞增子序列的優化
Constructing Roads In JGShining's Kingdom
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12371 Accepted Submission(s): 3526
Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.
Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.
With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.
Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.
The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.
But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
For example, the roads in Figure I are forbidden.
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.
With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.
Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.
The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.
But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.
For example, the roads in Figure I are forbidden.
In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to
the end of file.
Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
You should tell JGShining what's the maximal number of road(s) can be built.
Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
Sample Output
Case 1:
My king, at most 1 road can be built.
Case 2:
My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
Author
JGShining(極光炫影)
/*此題資料量略大,所以用dp直接求果斷TLE了,
所以經這道題我學習了一下優化的演算法,
也就是在計算以當前項結尾的最長遞增序列時使用二分查詢,
一次降低時間複雜度*/
//注意:輸出時單數road複數要用roads,此細節wa了無數次。。。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <deque>
using namespace std;
int r[500001];
//b[i]儲存的是長度為i的遞增序列的最小末尾項
int b[500001];
deque<int> q;
int DP(int n)
{
int i,left=1,mid=0,right=1,len=1;
b[1]=r[1];
for(i=2;i<=n;i++)//計算以每一項結尾的最長遞增序列
{
right=len;
left=1;
while(left<=right)//二分查詢
{
//對b陣列,從下標的中值也就是長度開始查詢,
//如果當前項比b[mid]大,
//那說明當前項可以插到長度比maxlen/2大的序列的尾部,
//於是將範圍縮小到後半段,接著使用二分,
//反之亦然
mid=(left+right)/2;
if(b[mid]<r[i])
left=mid+1;
else
right=mid-1;
}
b[left]=r[i];
if(left>len)
len+=1;
}
return len;
}
int main()
{
int n,t=0;
while(cin>>n)
{
t++;
memset(b,0,sizeof(dp));
int i,ans;
for(i=0;i<n;i++)
{
int rr,pp;
scanf("%d%d",&rr,&pp);
r[rr]=pp;
}
ans=DP(n);
cout<<"Case "<<t<<":"<<endl;
if(ans==1)
cout<<"My king, at most "<<ans<<" road can be built."<<endl;
else
cout<<"My king, at most "<<ans<<" roads can be built."<<endl;
cout<<endl;
}
return 0;
}
相關文章
- 最長遞增子序列
- 最長遞增子序列-Java 實現Java
- 673. 最長遞增子序列的個數
- Leetcode-300. 最長遞增子序列LeetCode
- LeetCode300.最長遞增子序列LeetCode
- [LintCode] Longest Increasing Subsequence 最長遞增子序列
- Leetcode 300 最長遞增子序列(LIS板題)LeetCode
- Leetcode 最小調整數+滑動視窗遞增子序列LeetCode
- 【修訂版】Leetcode 300 最長遞增子序列LeetCode
- 300-Longest Increasing Subsequnce-最長遞增子序列
- leetcode力扣 300. 最長遞增子序列LeetCode力扣
- [leetcode 中等 動態規劃]673. 最長遞增子序列的個數 [leetcode 簡單 滑動視窗] 674. 最長連續遞增序列 [筆試]陣列的遞增子陣列序列LeetCode動態規劃筆試陣列
- Day 28 | 491.遞增子序列 、46.全排列、 47.全排列 II
- 【LeetCode動態規劃#14】子序列系列題(最長遞增子序列、最長連續遞增序列、最長重複子陣列、最長公共子序列)LeetCode動態規劃陣列
- Day 45 | 300.最長遞增子序列 、674. 最長連續遞增序列 、718. 最長重複子陣列陣列
- CUDA程式優化心得之序列優化優化
- 【LeetCode回溯演算法#08】遞增子序列,鞏固回溯演算法中的去重問題LeetCode演算法
- 第二章 :查詢與排序-------2.19題目詳解_找出最長連續遞增子序列排序
- 遞迴尾呼叫優化遞迴優化
- 尾遞迴以及優化遞迴優化
- 【Scala】尾遞迴優化遞迴優化
- Javascript中的尾遞迴及其優化JavaScript遞迴優化
- 程式碼隨想錄演算法訓練營 | 300.最長遞增子序列,674. 最長連續遞增序列,718. 最長重複子陣列演算法陣列
- 用C++優雅的實現物件到檔案的序列化/反序列化C++物件
- 程式碼隨想錄演算法訓練營第49天 | 300.最長遞增子序列 、674. 最長連續遞增序列 、718. 最長重複子陣列演算法陣列
- 將 Intent 序列化,像 Uri 一樣傳遞 Intent!!!Intent
- 遞迴優化:尾呼叫和Memoization遞迴優化
- ?30 秒瞭解尾遞迴和尾遞迴優化遞迴優化
- 資訊化優化需要關注遞延價值優化
- ADAMoracle最大程度的優化預言機的執行效率Oracle優化
- Java的序列化和反序列化Java
- Java的序列化與反序列化Java
- win10最大優化cpu設定_win10如何優化cpuWin10優化
- SQL優化:組內排序取最大值SQL優化排序
- 物件序列化(序列化)物件
- python的序列化和反序列化Python
- Java中的序列化與反序列化Java
- UIImageView 序列幀動畫的實現以及記憶體的優化UIView動畫記憶體優化