Strange Way to Express Integers(中國剩餘定理+不互質)

尋找&星空の孩子發表於2015-05-03

Strange Way to Express Integers

Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%I64d & %I64u
 

Description

 

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

 

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ ik) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ ik).

 

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

 

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

 

題意:給你k組數。x%M[i]=A[i];

思路:中國剩餘定理,擴充套件歐幾里德

不會的可以參考:http://blog.csdn.net/u010579068/article/details/45422941

轉載請註明出處:尋找&星空の孩子

題目連結:http://poj.org/problem?id=2891

 

 

#include<stdio.h>
#define LL __int64

void exgcd(LL a,LL b,LL& d,LL& x,LL& y)
{
    if(!b){d=a;x=1;y=0;}
    else
    {
        exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
LL gcd(LL a,LL b)
{
    if(!b){return a;}
    gcd(b,a%b);
}

LL M[55000],A[55000];


LL China(int r)
{
    LL dm,i,a,b,x,y,d;
    LL c,c1,c2;
    a=M[0];
    c1=A[0];
    for(i=1; i<r; i++)
    {
        b=M[i];
        c2=A[i];
        exgcd(a,b,d,x,y);
        c=c2-c1;
        if(c%d) return -1;//c一定是d的倍數,如果不是,則,肯定無解
        dm=b/d;
        x=((x*(c/d))%dm+dm)%dm;//保證x為最小正數//c/dm是餘數,係數擴大餘數被
        c1=a*x+c1;
        a=a*dm;
    }
    if(c1==0)//餘數為0,說明M[]是等比數列。且餘數都為0
    {
        c1=1;
        for(i=0;i<r;i++)
            c1=c1*M[i]/gcd(c1,M[i]);
    }
    return c1;
}
int main()
{
    int n;

    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%I64d%I64d",&M[i],&A[i]);
        }
        if(n==1){ printf("%I64d\n",A[0]);continue;}
        LL ans=China(n);
        printf("%I64d\n",ans);

    }
    return 0;
}

 

相關文章