POJ1276Cash Machine[多重揹包可行性]

Candy?發表於2016-08-22
Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32971   Accepted: 11950

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

-----------------------------------------------------------------------------------------------
多重揹包可行性問題
法1:O(NVlogC)
二進位制拆分,w無意義,c和v不開陣列也可以
//  poj1276
#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=15,V=1e5+5;
int n,cash,f[V],c[N],w[N],v[N];

inline void zp(int v,int w){
    for(int i=cash;i>=v;i--)
        //f[i]=max(f[i],f[i-v]+w);
        f[i]=f[i]|f[i-v];
}
inline void cp(int v,int w){
    for(int i=v;i<=cash;i++)
//        f[i]=max(f[i],f[i-v]+w);
        f[i]=f[i]|f[i-v];
}
inline void mp(int v,int w,int c){
    if(c*v>=cash){cp(v,w);return;}
    int k=1;
    while(k<c){
        zp(k*v,k*c);
        c-=k;
        k*=2;
    }
    zp(v*c,w*c);
}
 
int main(int argc, const char * argv[]) {
    while(cin>>cash>>n){
        f[0]=1;
        memset(f,0,sizeof(f));    f[0]=1;
        for(int i=1;i<=n;i++){
            cin>>c[i]>>v[i];
            mp(v[i],w[i],c[i]);
        }
        for(int i=cash;i>=0;i--)if(f[i]>0){cout<<i<<"\n";break;}
    }
    return 0;
}

法2:O(NV) 然而卻比法1慢...............

f[i][j]表示前i種物品裝滿容量為j的揹包後還剩下幾個i,不可行為-1  

轉移先通過f[i-1][j]判斷可不可行,再用可行的f[i][j]更新f[i][j+vi](其實就是一遍完全揹包)

#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N=15,V=1e5+5;
int n,cash,f[N][V],c[N],v[N];

void mpAble(){
    memset(f,-1,sizeof(f));
    f[0][0]=0;
    for(int i=1;i<=n;i++){
        for(int j=0;j<=cash;j++){
            if(f[i-1][j]>=0) f[i][j]=c[i];
            else f[i][j]=-1;
        }
        for(int j=0;j<=cash-v[i];j++)
            if(f[i][j]>=0)
                f[i][j+v[i]]=max(f[i][j+v[i]],f[i][j]-1);
    }
}
int main(int argc, const char * argv[]) {
    while(cin>>cash>>n){
        for(int i=1;i<=n;i++) cin>>c[i]>>v[i];
        mpAble();
        for(int i=cash;i>=0;i--)if(f[n][i]>=0){cout<<i<<"\n";break;}
    }
    return 0;
}

 

 

相關文章