hdu 1326 java (理解起來很簡單)

YX_blog發表於2015-08-17

點選開啟連結

Box of Bricks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5841    Accepted Submission(s): 2536


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 
 

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.
 

Sample Input
6 5 2 4 1 7 5 0
 

Sample Output
Set #1 The minimum number of moves is 5.
 

Source
 
題目解釋:
題目意思很簡單,就是 給你n個數,然後通過程式設計變成n個都相等的數,問求怎麼移動的最小數目,然後按題目的要求輸出。每一個輸出之後都要換一行(這裡地方我PE了很多次),大家注意點就好。
package cn.hncu.acm;

import java.util.Scanner;

public class p1326 {

	public static void main(String[] args) {
			Scanner sc =new Scanner(System.in);//從鍵盤收數
			int d=0;
			while(sc.hasNext()){
			int n=sc.nextInt();//輸入n
			if(n==0){
				break;
			}
			int a[]=new int[n];//用來放n個數
			int sun=0,m=0;
			for(int i=0;i<n;i++){
				a[i]=sc.nextInt();
				sun=sun+a[i];//求n個數的和,求平均數
			}
			sun=sun/n;//求平均數
			
			//當求出平均數後,比平均數多出來的就必須移動其他的地方,也就是不會重複移動,也就是最少的移動路徑
			for(int i=0;i<n;i++){
				if(a[i]>sun){
					m=m+a[i]-sun;//求多出來的數字
					
				}
			}
			d=d+1;//為目標輸出 SEt # d
			System.out.println("Set #"+d);
			System.out.println("The minimum number of moves is "+m+".");
			System.out.println();//PE 是因為 最後沒有換行
	}
	}
}

相關文章