HDU 3080 The plan of city rebuild(prim和kruskal)
The plan of city rebuild
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 616 Accepted Submission(s): 215
Problem Description
News comes!~City W will be rebuilt with the expectation to become a center city. There are some villages and roads in the city now, however. In order to make the city better, some new villages should be built and some old ones should be destroyed. Then the
officers have to make a new plan, now you , as the designer, have the task to judge if the plan is practical, which means there are roads(direct or indirect) between every two villages(of course the village has not be destroyed), if the plan is available,
please output the minimum cost, or output"what a pity!".
Input
Input contains an integer T in the first line, which means there are T cases, and then T lines follow.
Each case contains three parts. The first part contains two integers l(0<l<100), e1, representing the original number of villages and roads between villages(the range of village is from 0 to l-1), then follows e1 lines, each line contains three integers a, b, c (0<=a, b<l, 0<=c<=1000), a, b indicating the village numbers and c indicating the road cost of village a and village b . The second part first contains an integer n(0<n<100), e2, representing the number of new villages and roads(the range of village is from l to l+n-1), then follows e2 lines, each line contains three integers x, y, z (0<=x, y<l+n, 0<=z<=1000), x, y indicating the village numbers and z indicating the road cost of village x and village y. The third part contains an integer m(0<m<l+n), representing the number of deserted villages, next line comes m integers, p1,p2,…,pm,(0<=p1,p2,…,pm<l+n) indicating the village number.
Pay attention: if one village is deserted, the roads connected are deserted, too.
Each case contains three parts. The first part contains two integers l(0<l<100), e1, representing the original number of villages and roads between villages(the range of village is from 0 to l-1), then follows e1 lines, each line contains three integers a, b, c (0<=a, b<l, 0<=c<=1000), a, b indicating the village numbers and c indicating the road cost of village a and village b . The second part first contains an integer n(0<n<100), e2, representing the number of new villages and roads(the range of village is from l to l+n-1), then follows e2 lines, each line contains three integers x, y, z (0<=x, y<l+n, 0<=z<=1000), x, y indicating the village numbers and z indicating the road cost of village x and village y. The third part contains an integer m(0<m<l+n), representing the number of deserted villages, next line comes m integers, p1,p2,…,pm,(0<=p1,p2,…,pm<l+n) indicating the village number.
Pay attention: if one village is deserted, the roads connected are deserted, too.
Output
For each test case, If all villages can connect with each other(direct or indirect), output the minimum cost, or output "what a pity!".
Sample Input
2
4 5
0 1 10
0 2 20
2 3 40
1 3 10
1 2 70
1 1
4 1 60
2
2 3
3 3
0 1 20
2 1 40
2 0 70
2 3
0 3 10
1 4 90
2 4 100
0
Sample Output
70
160
Author
wangjing
題目大意:先給你n1個點,m1條邊,又給你n2個點,m2條邊,然後告訴你有些點不需要,然後求剩下點的最
小生成樹。反正光看題目就花了半小時,真不明白了,老路,新路,給邊還分兩次給。。
用了prim和kruskal兩種演算法來實現,中間還debug了蠻久。
Prim演算法:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF =1e8;
int mp[205][205];
int des[205];
int visi[205];
int low[205]; //更新最小值
int n;
int prim()
{
int i,j;
memset(visi,0,sizeof(visi));
for(i=0;i<=200;i++)
low[i]=INF;
int ans=0,pos=-1;
for(i=0;i<n;i++)
{
if(!des[i])
{
pos=i;
break;
}
}
if(pos==-1) return 0;
for(i=0;i<=200;i++)
low[i]=mp[pos][i];
visi[pos]=1;
int mi;
for(i=0;i<n;i++)
{
mi=INF;
int flag=0;
for(j=0;j<n;j++)
{
if(des[j]) continue;
if(!visi[j])
{
flag=1;
if(low[j]<mi)
{
mi=low[j];
pos=j;
}
}
}
if(mi==INF&&flag)
return -1;
if(!flag) return ans;
ans+=mi;
visi[pos]=1;
for(j=0;j<n;j++)
if(!visi[j])
low[j]=min(low[j],mp[pos][j]);
}
return ans;
}
int main()
{
int tes,i,j,res;
scanf("%d",&tes);
while(tes--)
{
int n1,m,u,v,val;
scanf("%d%d",&n1,&m);
for(i=0;i<=200;i++)
for(j=0;j<=200;j++)
mp[i][j]=INF;
memset(des,0,sizeof(des));
for(i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&val);
if(mp[u][v]>val) //這個地方,邊可能會多次給出,坑。。
{
mp[u][v]=val;
mp[v][u]=val;
}
}
int n2;
scanf("%d%d",&n2,&m);
for(i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&val);
if(mp[u][v]>val)
{
mp[u][v]=val;
mp[v][u]=val;
}
}
n=n1+n2;
int t,x;
scanf("%d",&t);
for(i=0;i<t;i++)
{
scanf("%d",&x);
des[x]=1;
}
res=prim();
if(res==-1) puts("what a pity!");
else printf("%d\n",res);
}
return 0;
}
Kruskal演算法:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF =1e6;
const int maxn=205;
int n,m,t; //總點數,總邊數,desert的邊數
int des[maxn]; //為1代表城市荒廢
int fa[maxn];
struct Edge
{
int from;
int to;
int val;
}edge[maxn*maxn];
int cmp(Edge p1,Edge p2)
{
//if(des[p1.from]||des[p1.to]) return 0;
//if(des[p2.from]||des[p2.to]) return 1;
return p1.val<p2.val;
}
void init()
{
for(int i=0;i<=200;i++)
fa[i]=i;
}
int find1(int x)
{
if(fa[x]!=x) fa[x]=find1(fa[x]);
return fa[x];
}
void merge1(int p1,int p2)
{
p1=find1(p1);
p2=find1(p2);
fa[p1]=p2;
}
int Kruskal()
{
sort(edge,edge+m,cmp);
int ans=0,ste=0;
for(int i=0;i<m&&ste<n-t-1;i++)
{
int u=edge[i].from,v=edge[i].to,val=edge[i].val;
if(des[u]||des[v]) continue;
if(find1(u)!=find1(v))
{
ste++;
ans+=val;
merge1(u,v);
}
}
if(ste==n-t-1) return ans;
return -1;
}
int main()
{
int tes,i,j,res;
scanf("%d",&tes);
while(tes--)
{
int n1,m1,u,v,val,n2,m2;
scanf("%d%d",&n1,&m1);
memset(des,0,sizeof(des));
for(i=0;i<m1;i++)
{
scanf("%d%d%d",&u,&v,&val);
edge[i].from=u;
edge[i].to=v;
edge[i].val=val;
}
scanf("%d%d",&n2,&m2);
n=n1+n2;
m=m1+m2;
for(i=m1;i<m;i++)
{
scanf("%d%d%d",&u,&v,&val);
edge[i].from=u;
edge[i].to=v;
edge[i].val=val;
}
int x;
scanf("%d",&t);
for(i=0;i<t;i++)
{
scanf("%d",&x);
des[x]=1;
}
init();
res=Kruskal();
//cout<<n<<" :n"<<endl;
if(res==-1) puts("what a pity!");
else printf("%d\n",res);
}
return 0;
}
相關文章
- 圖解Prim&Kruskal演算法圖解演算法
- 最小生成樹:Kruskal演算法和Prim演算法演算法
- 最小生成樹-Prim演算法和Kruskal演算法演算法
- 最小生成樹之Prim演算法和Kruskal演算法演算法
- 最小生成樹---普里姆演算法(Prim演算法)和克魯斯卡爾演算法(Kruskal演算法)演算法
- 聊聊索引Index Rebuild和Rebuild Online(下)索引IndexRebuild
- 索引rebuild和rebuild online時要慎重索引Rebuild
- 聊聊索引Index Rebuild和Rebuild Online(上)索引IndexRebuild
- 最小生成樹,Prim演算法與Kruskal演算法,408方向,思路與實現分析演算法
- alter index rebuild和rebuild online的區別IndexRebuild
- 索引rebuild和rebuild online時要慎重(轉載)索引Rebuild
- HDU 4252A Famous City(弱資料可以使用貪心)
- Kruskal algorithmGo
- Oracle --- PLAN_TABLE$和PLAN_TABLE區別Oracle
- animate()動畫的opacity: 'show'和opacity: 'hide'作用動畫IDE
- 【羅玄】從鎖的角度看rebuild index online和rebuild indexRebuildIndex
- 3080顯示卡怎麼樣 3080顯示卡可以玩什麼遊戲遊戲
- alter index ind1 rebuild 和alter index ind1 rebuild onlineIndexRebuild
- Kruskal演算法演算法
- Kruskal重構樹
- Kruskal 重構樹
- alter index rebuild 與 rebuild onlineIndexRebuild
- Rebuild IndexesRebuildIndex
- rebuild indexRebuildIndex
- index rebuildIndexRebuild
- Rebuild TreeRebuild
- explain plan VS execution planAI
- Note - kruskal 重構樹
- rebuild與rebuild online效率比對Rebuild
- SAP ABAP SQL的execution plan和cacheSQL
- rebuild index 排序RebuildIndex排序
- sybase rebuild indexRebuildIndex
- 【Kmp】Blue Jeans POJ - 3080KMP
- 最小生成樹——Prim演算法和Kruscal演算法演算法
- Keil中translate,build和rebuild有什麼區別Rebuild
- Teamcity
- audacity
- wenxue city