hdu 1069 Monkey and Banana(簡單dp)
Monkey and Banana
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 6406 Accepted Submission(s): 3270
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
題目大意:主要是在讀題目時花了不少時間,就是給你n組x,y,z,然後x,y,z可以任意組合形成一個長方體的長寬高,那麼排列是有6種,然後我們可以將這6*n個長方體,選一些出來,使得立方體能夠一個挨一個從下面往上摞在一起,如果a摞在b上面,那麼需要ax<bx&&ay<by或者ax<by&&ay<bx,就是上面的可以摞在上面,然後求解這些長方體可以摞在一起的最大的高之和。
解題思路:我們可以先選取一個作為高,然後把其它兩個分別作為長和寬,我們如果規定長>=寬,那麼每次擴張6種可以壓縮成為3種。n最大為30,可以先對這3n個立方體排序然後動態規劃即可。具體見程式碼。
題目地址:Monkey and Banana
AC程式碼:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int x;
int y;
int z;
}nod[105];
int dp[105];
int cmp(node a,node b)
{
if(a.x<b.x) return 1;
if(a.x==b.x&&a.y<b.y) return 1;
return 0;
}
int main()
{
int n,cas=1;
while(cin>>n&&n>0)
{
int i,j,m=0;
int a[3];
for(i=0;i<n;i++)
{
cin>>a[0]>>a[1]>>a[2]; //每種有6種情況,但是由於x1<x2&&y1<y2可以縮減為3種情況
nod[m].x=max(a[0],a[1]),nod[m].y=min(a[0],a[1]),nod[m++].z=a[2];
nod[m].x=max(a[1],a[2]),nod[m].y=min(a[1],a[2]),nod[m++].z=a[0];
nod[m].x=max(a[0],a[2]),nod[m].y=min(a[0],a[2]),nod[m++].z=a[1];
}
sort(nod,nod+m,cmp);
for(i=0;i<m;i++)
{
int ma=0;
for(j=0;j<i;j++)
{
if(nod[j].x<nod[i].x&&nod[j].y<nod[i].y)
ma=max(ma,dp[j]);
}
dp[i]=ma+nod[i].z;
}
int res=0;
for(i=0;i<m;i++)
res=max(res,dp[i]);
printf("Case %d: maximum height = %d\n",cas++,res);
}
return 0;
}
/*
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
*/
相關文章
- 【dp】HDU - 1069 Monkey and BananaNaN
- 「暑期訓練」「基礎DP」 Monkey and Banana (HDU-1069)NaN
- zoj 1093 dp Monkey and BananaNaN
- hdu1069javaJava
- HDU 1227 Fast Food(簡單二維dp)AST
- HDU 5119 Happy Matt Friends(簡單二維dp)APP
- hdu 3401 單調佇列+DP佇列
- HDU 1466 計算直線的交點數(簡單dp)
- hdu4374單調佇列+dp佇列
- HDU 3530 Subsequence (dp+單調佇列)佇列
- HDU 3853 LOOPS(概率dp)OOP
- HDU 4669 Mutiples on a circle (DP , 統計)
- hdu 3665Seaside(簡單floyd)IDE
- 【基礎dp】HDU 1260 Tickets
- HDU 4455 Substrings(預處理+dp)
- hdu5365 簡單幾何問題
- HDU 6415 Rikka with Nash Equilibrium (DP)UI
- HDU 3853 LOOPS:期望dp【網格型】OOP
- HDU 5119 Happy Matt Friends(DP)APP
- HDU 5326 Work (基礎樹形dp)
- hdu 4123 樹形DP+RMQMQ
- HDU 4770 Lights Against Dudely(列舉所有狀態 當然壯壓dp會很簡單)AI
- hdu 4287Intelligent IME(簡單hash)Intel
- hdu 1326 java (理解起來很簡單)Java
- URAL 1658. Sum of Digits(簡單dp)Git
- HDU3415 Max Sum of Max-K-sub-sequence (DP+單調佇列)佇列
- HDU6415:Rikka with Nash Equilibrium(dp)UI
- 【基礎dp】HDU 1176 免費餡餅
- HDU 5067 Harry And Dig Machine(狀壓dp)Mac
- hdu 1789 Doing Homework again(簡單貪心)AI
- HDU 1241Oil Deposits(簡單搜尋題)
- HDU 4422 The Little Girl who Picks Mushrooms(簡單題)OOM
- hdu 1237 Java 簡單計算器Java
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- HDU4427Math Magic (dp+滾動陣列)陣列
- hdu 3507 斜率優化DP入門題優化
- hdu ---(4517)小小明系列故事——遊戲的煩惱(Dp)遊戲
- HDU3944 DP? (LUCAS定理+階乘預處理)