POJ 1837Balance(動態規劃 好題)
Balance
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 9615 | Accepted: 5933 |
Description
Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.
Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.
Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.
Input
The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.
Output
The output contains the number M representing the number of possibilities to poise the balance.
Sample Input
2 4 -2 3 3 4 5 8
Sample Output
2
給一個天平,然後有許多砝碼,問把砝碼加上去達到平衡狀態的方案數。
測試用例分析:
2 4 代表有在天平上有兩個鉤子,砝碼有四種
-2 3 鉤子的位置,負數代表在左邊,正數代表在右邊
3 4 5 8 分別給出四種砝碼的重量
什麼時候達到平衡呢?就是臂力=臂長*重量,當兩邊的臂力相等的時候就會平衡了。
題目說的意思是所有的砝碼都要用到,我們先分析一下樣例。
取第一個砝碼 -6 9
取第二個砝碼 -14 6 1 21
取第三個砝碼 -24 1 -4 21 -9 16 11 36
取第四個砝碼 -40 0 0 40
由於第四行太多,沒有全部列舉,可以看出來,共有兩種方案。我們可以使用動態規劃的思想,從上層往下層遞推。
為了避免負數的出現,我們分析資料g*pos*wei<=20*15*25=7500那麼範圍就是-7500~7500,那麼我們可以使用
dp[25][1500]的揹包裝這些砝碼,狀態轉移方程為dp[i][j+pos[k]*wei[i]]+=dp[i-1][j];
當然首先得初始化dp[0][7500]=0,標誌未放砝碼時,7500位置為平衡點。
最後的答案即為dp[g][7500]。
題目地址:Balance
看了幾小時,終於看懂了。。哭。
AC程式碼:
#include<iostream>
#include<cstring>
using namespace std;
int dp[25][15001];
int pos[25],wei[25];
int main()
{
int c,g;
int i,j,k;
while(cin>>c>>g)
{
for(i=1; i<=c; i++)
cin>>pos[i];
for(i=1; i<=g; i++)
cin>>wei[i];
memset(dp,0,sizeof(dp));
dp[0][7500]=1; //一個砝碼也不掛
for(i=1; i<=g; i++) //g個砝碼
for(j=0; j<=15000; j++)
if(dp[i-1][j]) //說明可以在往上面掛
for(k=1; k<=c; k++) //c個位置
dp[i][j+wei[i]*pos[k]]+=dp[i-1][j];
cout<<dp[g][7500]<<endl;
}
return 0;
}
/*
2 2
-1 1
2 2
2 3
-1 1
2 3 5
*/
相關文章
- 好題——動態規劃動態規劃
- 動態規劃專題動態規劃
- 動態規劃題單動態規劃
- 動態規劃練習題動態規劃
- 動態規劃解題方法動態規劃
- 動態規劃做題思路動態規劃
- 【動態規劃(一)】動態規劃基礎動態規劃
- 整數劃分問題(動態規劃)動態規劃
- 博弈論專題——推理與動態規劃相關博弈之POJ2348動態規劃
- 博弈論專題——推理與動態規劃相關博弈之POJ2484 POJ1740(模仿遊戲)動態規劃遊戲
- 動態規劃 擺花 題解動態規劃
- 動態規劃之子序列問題動態規劃
- 揹包問題----動態規劃動態規劃
- 【動態規劃】揹包問題動態規劃
- 做題記錄 --- 動態規劃動態規劃
- 我的動態規劃題單動態規劃
- 動態規劃動態規劃
- 動態規劃9:變態跳臺問題動態規劃
- 動態規劃 01揹包問題動態規劃
- 找零問題與動態規劃動態規劃
- 【動態規劃】01揹包問題動態規劃
- leetcode題解(動態規劃)LeetCode動態規劃
- 動態規劃-01揹包問題動態規劃
- 動態規劃,股票問題留坑動態規劃
- 動態規劃篇——揹包問題動態規劃
- 醜數問題——動態規劃、Java動態規劃Java
- (動態規劃)最小分糖果問題動態規劃
- 動態規劃--01揹包問題動態規劃
- 一維動態規劃和二維動態規劃中兩道經典題目動態規劃
- 動態規劃分析動態規劃
- 動態規劃(DP)動態規劃
- 動態規劃初步動態規劃
- 模板 - 動態規劃動態規劃
- 動態規劃法動態規劃
- 【動態規劃】01揹包問題【續】動態規劃
- 動態規劃分類題目總結動態規劃
- 動態規劃5:找零錢問題動態規劃
- 演算法系列-動態規劃(1):初識動態規劃演算法動態規劃