hdu 3665Seaside(簡單floyd)

果7發表於2013-11-01

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1006    Accepted Submission(s): 722


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
2
 

Source
 


題目意思很好懂,當時我們竟然想到了一步步dp,範圍很小,n最大才為10而已,可以直接用floyd,只是一直不敢交,覺得存在bug,因為n為0的時候不知道怎麼處理。。最後突然交了一發,A了,應該沒有n=0的資料。。

題目地址:Seaside

AC程式碼:
#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 1e12
using namespace std;
long long dis[15][15];
int issea[15],n;

void floyd()
{
    int i,j,k;
    for(k=0;k<n;k++)
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                if(dis[i][j]>dis[i][k]+dis[k][j])
                   dis[i][j]=dis[i][k]+dis[k][j];
}

int main()
{
    int i,j;
    long long ans;
    while(cin>>n)
    {
        ans=maxn;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
                dis[i][j]=maxn;
            dis[i][i]=0;
        }

        memset(issea,0,sizeof(issea));  //是否是海邊
        for(i=0;i<n;i++)
        {
            int a,b,c,d;
            scanf("%d%d",&a,&b);
            issea[i]=b;
            for(j=0;j<a;j++)
            {
                scanf("%d%d",&c,&d);
                dis[i][c]=d;
            }
        }
        floyd();
        for(i=0;i<n;i++)
            if(issea[i]&&dis[0][i]<ans)
                ans=dis[0][i];
        cout<<ans<<endl;
    }
    return 0;
}

相關文章