hdu 4287Intelligent IME(簡單hash)
Intelligent IME
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1810 Accepted Submission(s): 897
Problem Description
We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o
7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z
When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
Input
First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
Output
For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
Sample Input
1
3 5
46
64448
74
go
in
night
might
gn
Sample Output
3
2
0
Source
題目意思就不多說了,將下面的字串hash對映到上面的數字上即可。
AC程式碼:
#include<iostream>
#include<cstring>
using namespace std;
int hash1[1000005];
int a[5005];
char b[5005][8];
int cal(char *s)
{
int tmp=0;
int len=strlen(s),i;
for(i=0;i<len;i++)
{
if(s[i]>='a'&&s[i]<='c') tmp=tmp*10+2;
else if(s[i]>='d'&&s[i]<='f') tmp=tmp*10+3;
else if(s[i]>='g'&&s[i]<='i') tmp=tmp*10+4;
else if(s[i]>='j'&&s[i]<='l') tmp=tmp*10+5;
else if(s[i]>='m'&&s[i]<='o') tmp=tmp*10+6;
else if(s[i]>='p'&&s[i]<='s') tmp=tmp*10+7;
else if(s[i]>='t'&&s[i]<='v') tmp=tmp*10+8;
else if(s[i]>='w'&&s[i]<='z') tmp=tmp*10+9;
}
return tmp;
}
int main()
{
int tes,i;
cin>>tes;
while(tes--)
{
int n,m;
cin>>n>>m;
for(i=0;i<n;i++)
cin>>a[i]; //存放數字
for(i=0;i<m;i++)
cin>>b[i];
memset(hash1,0,sizeof(hash1));
for(i=0;i<m;i++)
hash1[cal(b[i])]++;
for(i=0;i<n;i++)
cout<<hash1[a[i]]<<endl;
}
return 0;
}
//406MS
相關文章
- Hash破解神器:Hashcat的簡單使用
- hdu 3665Seaside(簡單floyd)IDE
- hdu 3973 字串hash+線段樹字串
- hdu5365 簡單幾何問題
- hdu 1326 java (理解起來很簡單)Java
- HDU 1227 Fast Food(簡單二維dp)AST
- hdu 1069 Monkey and Banana(簡單dp)NaN
- hdu 1789 Doing Homework again(簡單貪心)AI
- HDU 1241Oil Deposits(簡單搜尋題)
- HDU 4422 The Little Girl who Picks Mushrooms(簡單題)OOM
- hdu 1237 Java 簡單計算器Java
- 簡單的揹包問題(入門)HDU2602 HDU2546 HDU1864
- HDU 1272小希的迷宮(簡單並查集)並查集
- javascript獲取字串的hash值簡單程式碼例項JavaScript字串
- 一致性hash的c++簡單實現C++
- HDU 5119 Happy Matt Friends(簡單二維dp)APP
- ACM HDU 1279 驗證角谷猜想(簡單水題)ACM
- flinkSql join redis的hash結構維表簡單實現SQLRedis
- HDU_1237 一個簡單的計算器
- HDU 1466 計算直線的交點數(簡單dp)
- HDU1788Chinese remainder theorem again(中國剩餘定理 簡單)REMAI
- LeetCode C++ 204. Count Primes【Math/Hash Table】簡單LeetCodeC++
- HDU 1077Catching Fish(簡單計算幾何)
- CSS文字:ime-mode(轉)CSS
- hdu 3415 單調佇列佇列
- w10已禁用ime怎麼解決_w10已禁用ime如何恢復
- Binary Tree Traversals(HDU1710)二叉樹的簡單應用二叉樹
- LeetCode C++ 387. First Unique Character in a String【String/Hash Table】簡單LeetCodeC++
- hdu 2072 Java 單詞數(超級坑) HDU 2072Java
- 初探WINDOWS下IME程式設計 (轉)Windows程式設計
- HDU 3530 單調佇列佇列
- hdu 3401 單調佇列+DP佇列
- hdu 4122 單調佇列佇列
- win10輸入法ime模式如何開啟_win10怎樣取消電腦禁用imeWin10模式
- HDU 4548美素數(簡單題 儲存結果時需要注意不要超時)
- 基於react的hash路由簡易實現React路由
- hdu4374單調佇列+dp佇列
- HDU 4565 So Easy!(公式化簡+矩陣)公式矩陣