HDU 4252A Famous City(弱資料可以使用貪心)

果7發表於2013-10-25

A Famous City

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1504    Accepted Submission(s): 563


Problem Description
After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:
- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building, or no buildings at all.
- measure the height of each building in that piece.
- write a program to calculate the minimum number of buildings.
Mr. B has finished the first two steps, the last comes to you.
 

Input
Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the input numbers will be nonnegative and less than 1,000,000,000.
 

Output
For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.
 

Sample Input
3 1 2 3 3 1 2 1
 

Sample Output
Case 1: 3 Case 2: 2
Hint
The possible configurations of the samples are illustrated below:
 

Source
 


題目大意:把一片房子等分成很多份,每一片有自己的高度,第二張圖中間藍色的被棕色的擋住了。問你最少是多少棟樓。

解題思路:開始想錯了,直接理解為同一高度的都可以是一棟樓,但是中間如果出現矮的話就不行了,因為擋不住自己可以畫一下。後來採用貪心的策略,每個點儘量包含後面多的點。碰到比它高的直接跳過,跟他一樣的清零,比他矮的終止。演算法的複雜度沒有降下來。。可以用rmq降到O(N*LOG(N))

題目地址:A Famous City

AC程式碼:
#include<iostream>
#include<cstdio>
#define maxn 100005
using namespace std;
int a[maxn];

int main()
{
    int n;
    int tes=0,i,j,res;
    while(cin>>n)
    {
        res=0;
        for(i=0;i<n;i++)
            cin>>a[i];
        for(i=0;i<n;i++)
        {
            if(a[i])
            {
                for(j=i+1;j<n;j++)
                {
                    if(a[j]==a[i]) a[j]=0;
                    else if(a[j]<a[i]) break;
                }
                res++;
            }
        }

        printf("Case %d: %d\n",++tes,res);
    }
    return 0;
}

//468MS






相關文章