hdu 1754 【線段樹/RMQ】I Hate It

ACM_e發表於2017-11-14

Problem Description
很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。

不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模擬老師的詢問。當然,老師有時候需要更新某位同學的成績。
 

Input
本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別代表學生的數目和操作的數目。
學生ID編號分別從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (只取'Q'或'U') ,和兩個正整數A,B。
當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。
 

Output
對於每一次詢問操作,在一行裡面輸出最高成績。
 

Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin

wa  這個題賊坑   N 的實際資料 比較大  然後我 用 scanf 輸入的時候用的地址  a+j 這種   陣列開小導致到後面 尼瑪指標亂飛 就 tle 了 找了一下午 bug  氣哭  簡直要被 線段樹氣死

模板題

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
#define maxn 400000+10000
int a[maxn];
int tre[maxn*5];
void build(int in,int l,int r){
   if(l==r){
      tre[in]=a[l];
      return ;
   }
   int mid=(l+r)/2;
   build(in*2,l,mid);
   build(in*2+1,mid+1,r);
   tre[in]=max(tre[in*2],tre[in*2+1]);
}
void updata(int in,int va,int l,int r,int z){
    if(l==r){
        tre[z]=va;
        return ;
    }
    int mid=(l+r)/2;
    if(in>mid){
        updata(in,va,mid+1,r,z*2+1);
    }
    else updata(in,va,l,mid,z*2);
    //std::cout<<tre[in]<<" ";
    tre[z]=max(tre[z*2],tre[z*2+1]);
}
int query(int x,int y,int l,int r,int in){
   if(l==x&&y==r){
      return tre[in];
   }
   int mid=(l+r)/2;
   int mx=0,mx1=0,mx2=0;
   if(y<=mid){
      mx1=query(x,y,l,mid,in*2);
   }
   else if(x>mid){
      mx2=query(x,y,mid+1,r,in*2+1);
   }
   else {
      int x1=query(x,mid,l,mid,in*2);
      int x2=query(mid+1,y,mid+1,r,in*2+1);
      mx=max(mx,max(x1,x2));
   }
   mx=max(mx1,max(mx,mx2));
   return mx;
}
int main(){
   int n,m;
   while(scanf("%d%d",&n,&m)!=EOF){
       for(int j=1;j<=n;j++){
          scanf("%d",a+j);
       }
       build(1,1,n);
       char c; int x,y;
       while(m--){
          cin>>c;
          scanf("%d%d",&x,&y);
          if(c=='Q'){
             int sum=query(x,y,1,n,1);
             printf("%d\n",sum);
          }
          else{
             //   std::cout<<":1";
             updata(x,y,1,n,1);
          }
       }
   }
   return 0;
}




















相關文章